Network heavy loaded
Resolved
This incident has been resolved.
Posted Mar 17, 2021 - 12:36 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 17, 2021 - 12:20 CST
This incident affected: Account and Access (NCPA NetID login) and Email, Messaging and Collaboration (Office 365).